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Overview



• Interactive, web-based 3D structure 
viewer

• No installation needed! 

• Users can

• Visualize structure in 1D, 2D, and 3D 

• View sequence and structure 
alignments

• Probe perturbations

• Save/share links of their customized 
display

iCn3D



• Use iCn3D in Jupyter Notebook: pypi.org/project/icn3dpy

• 3D printing:  structure.ncbi.nlm.nih.gov/icn3d/share.html?wt4TDqzhC2rhCYTD7

• Contact map: structure.ncbi.nlm.nih.gov/icn3d/share.html?rnMbe26tNsAjJLGK9

• Precalculated symmetry: structure.ncbi.nlm.nih.gov/icn3d/share.html?bGH1BfLsiGFhhTDn8

• Symmetry dynamically: structure.ncbi.nlm.nih.gov/icn3d/share.html?6NvhQ45XrnbuXyGe6

• Electron density map: structure.ncbi.nlm.nih.gov/icn3d/share.html?QpqNZ3k65ToYFvUB6

• EM map:  structure.ncbi.nlm.nih.gov/icn3d/share.html?L4C4WYE85tYRiFeK7

• Transmembrane protein: structure.ncbi.nlm.nih.gov/icn3d/share.html?jMN16mJyR9STUx6E6

• Solvent Accessible Area: structure.ncbi.nlm.nih.gov/icn3d/share.html?xKSyfd1umbKstGh29

iCn3D Features of Interest

pypi.org/project/icn3dpy
https://structure.ncbi.nlm.nih.gov/icn3d/share.html?wt4TDqzhC2rhCYTD7
structure.ncbi.nlm.nih.gov/icn3d/share.html?rnMbe26tNsAjJLGK9
https://structure.ncbi.nlm.nih.gov/icn3d/share.html?bGH1BfLsiGFhhTDn8
https://structure.ncbi.nlm.nih.gov/icn3d/share.html?6NvhQ45XrnbuXyGe6
https://structure.ncbi.nlm.nih.gov/icn3d/share.html?QpqNZ3k65ToYFvUB6
https://structure.ncbi.nlm.nih.gov/icn3d/share.html?L4C4WYE85tYRiFeK7
https://structure.ncbi.nlm.nih.gov/icn3d/share.html?jMN16mJyR9STUx6E6
https://structure.ncbi.nlm.nih.gov/icn3d/share.html?xKSyfd1umbKstGh29


New Features!

• Virtual reality view

• Batch analysis



• Updated monthly

• Derived from PDB records

• Additional information added, 
including:

• Explicit chemical graph 
information

• Validation (secondary structure 
elements)

• Includes taxonomy

• Connects 3D to associated 
literature, molecular data, chemical 
data, and other NCBI tools

Structure Database



Rotate
• Left mouse button can be used 

to rotate the structure

• Key L - left

• Key J - right

• Key I - up

• Key M - down

Zoom
• Middle mouse button can be 

used to zoom

• Left Mouse + Shift can be used 
as an alternative to the middle 
mouse button

• Key Z - zoom in

• Key X - zoom out

iCn3D Shortcuts Translate
• Right mouse button - can be 

used to translate (slide) the 
structure to a different location 
within the 3D window

• Left Mouse + Ctrl can be used as 
an alternative to the right mouse 
button

• Arrow Left - left

• Arrow Right - right

• Arrow Up - up

• Arrow Down - down

Select
• Alt + Click (PC) or Option + Click 

(Mac)- can be used to select 
atom/residue/strand , hold Ctrl + 
Click to add another 

iCn3D Help Document

https://structure.ncbi.nlm.nih.gov/icn3d/share.html?PrJm9U7w2irwV2pT7


• Click full-feature 3D viewer on the Molecular Graphic 

• Or go to https://www.ncbi.nlm.nih.gov/Structure/icn3d/full.html

• Input 1TUP > Load Biological Unit

• Orient yourself (see iCn3D Shortcuts for help)

• Hover over structure with your mouse to view residues

• Select > Select on 3D > Atom to see atomistic details

• You can revert to selecting by residues Select > Select on 3D > 

Residue

iCn3D Demo (1/5)

https://structure.ncbi.nlm.nih.gov/icn3d/share.html?PrJm9U7w2irwV2pT7

https://www.ncbi.nlm.nih.gov/Structure/icn3d/full.html
https://structure.ncbi.nlm.nih.gov/icn3d/share.html?PrJm9U7w2irwV2pT7


• Change styling with Style > Sidechains > Lines

• Explore different Style options

• Explore different Color options

• Chain – default, colors structural components differently

• Rainbow – N-term or 5’ end is red and flows to blue for C-term or 3’ end

• Charge – colors positively charged as blue, negatively charged as red, and neutral 

as gray

• Atom – colors C gray, O red, N blue, S yellow

• Secondary, Hydrophobicity, and Solvent Accessibility options are useful 

for more in-depth analysis of structure

iCn3D Demo (2/5)

https://structure.ncbi.nlm.nih.gov/icn3d/share.html?GkfzpCjxnCF8L79o6

https://structure.ncbi.nlm.nih.gov/icn3d/share.html?GkfzpCjxnCF8L79o6


• Make specific selections with Analysis > Defined Sets

• Select nucleotides and change color with Color > Rainbow

• Select residues by sequence with Analysis > Seq. & Annotations

• Uncheck annotations and click Details

• Highlight residues from the sequence to select

• Close or minimize Seq. & Annotations when not using

iCn3D Demo (3/5)

https://structure.ncbi.nlm.nih.gov/icn3d/share.html?F9ZUDzWifapM8ZiXA

https://structure.ncbi.nlm.nih.gov/icn3d/share.html?F9ZUDzWifapM8ZiXA


• Explore ion interactions with Select > By 

Distance

• Choose ions

• Set sphere radius to 5 Å

• Choose non-selected

• Change the style of these residues with   

Style > Proteins > Stick

• Save the selection by Select > Save 

Selection and give name like resi_5a_zn

iCn3D Demo (4/5)

https://structure.ncbi.nlm.nih.gov/icn3d/share.html?qmYR6yC46RHsUYMe8

https://structure.ncbi.nlm.nih.gov/icn3d/share.html?qmYR6yC46RHsUYMe8


• View the ion interactions Analysis > Defined Sets > ions and 

your newly named selection resi_5a_zn and View > View 

Selection

• Change your background color with Style > Background

• Saving your files

• As a PNG with File > Save Files > iCn3D PNG image

• As an interactive link with File > Share Link and copy

• For 3D printing with File > 3D Printing

iCn3D Demo (5/5)

https://structure.ncbi.nlm.nih.gov/icn3d/share.html?PwwbXdh9fnBs6gyy7

https://structure.ncbi.nlm.nih.gov/icn3d/share.html?PwwbXdh9fnBs6gyy7


• If you select something accidentally Select > Clear Selection

• If you need to undo View > Undo

• Get additional help by:

• Show Help > Help Docs

• Help > Selection Hints

• Like what you’ve rendered? Share your interactive link in the chat! 

• Ask us!   

iCn3D Exploration 5-minute exercise!



• P53 binds to regulatory sites in the genome 

and:

• Initiates protein production that stops cell 

division until damage is repaired

• Initiates apoptosis

• Rich in + charged amino acids (Arg, His, Lys)

• + charged amino acids commonly interact 

with negatively charged nucleic acid 

backbones

• Usually interact at the major grove

P53 DNA-binding

P53 DNA- binding (from PDB)



Mutation Example 1 

• Go to back to iCn3D

• What residues seem important to P53-binding domain? 

Select > by Distance

• Take a closer look at these residues 

Style > Protein > Stick

• Lys120 points into the major groove to make bas-

specific contact. How might a mutation affect 

interactions?

• Analysis > Mutation > 1TUP_B_120_A and select 

Interactions

https://structure.ncbi.nlm.nih.gov/icn3d/share.html?YKGoBvXsu5qGJxF77


Mutation Discussion 1 

• K120A mutation results in loss of interaction with the DNA groove

Mutant A120Wild type K120

https://structure.ncbi.nlm.nih.gov/icn3d/share.html?m2WRbHGknzAtXj9U7


• Literature shows that Arg248 and 

Arg273 are common P53 mutations 

implicated in disease

• Use the Mutation analysis to 

understand how these mutations may 

affect interactions

1TUP_B_248_W

1TUP_B_273_H

Mutation Example 2 5-minute exercise!



Mutation Discussion 2

• R248W mutation results in loss of hydrogen and salt bridge interactions

Mutant W248Wild type R248

https://structure.ncbi.nlm.nih.gov/icn3d/share.html?ULD3yoyfCWwjTScc9


Mutation Discussion 3

• R273H mutation results in loss of hydrogen bond interactions

Mutant H273Wild type R273

https://structure.ncbi.nlm.nih.gov/icn3d/share.html?FLHzKHsvUzLmBj517


Tutorials and help documents are available here.

Continue learning about iCn3D

https://www.ncbi.nlm.nih.gov/Structure/icn3d/icn3d.html#gallery


• Join us for workshops, webinars, or 

codeathons!

NCBI Insights Blog

• Follow us on social media:

• Twitter

• LinkedIn

• Facebook

Continue learning about NCBI Resources

https://ncbiinsights.ncbi.nlm.nih.gov/ncbi-outreach-events/
https://twitter.com/ncbi
https://www.linkedin.com/company/ncbinlm/
https://www.facebook.com/ncbi.nlm


Exploring 3D Molecular Structures with iCn3D
Supplemental Learning Materials
Alexa M. Salsbury, Ph.D. 



Structural Biology

1952-1953- Pioneering DNA 

structure work by Wilkins, 

Franklin, Watson, & Crick. 

1957- The first protein with a 

crystal structure was solved in 

by Kendrew and co-workers

1956-1960- Rich & Davies’ 

structural experiments showed 

how information could be 

transferred from DNA to RNA.

Now- over 175,000 

structures are publicly 

available!



Impact of Structures on New Drug Approvals

Westbrook & Burley (2019) Structure 27, 211-217

Galkina Cleary et al. (2018) PNAS 115, 2329-2334



Westbrook & Burley (2019) Structure 27, 211-217

Impact of Structures on Anti-Cancer Drug Approvals



To keep you alive, your body 

must:

• Convert oxygen to usable energy

• Digest food and recover nutrients

• Build and maintain body tissue

• Fight off invasions and detoxify 

poisons

Proteins do all these things!



Protein Structure

• Primary- sequence of amino acids

• Secondary- hydrogen bonding of the 

peptide backbone that causes amino 

acids to fold into a repeating pattern

• Tertiary- 3D folding pattern of a protein 

due to side chain interactions

• Quaternary- protein consisting of more 

than one polypeptide 

P
ri

m
a

ry
S

e
c
o

n
d

a
ry

T
e

rt
ia

ry
Q

u
a

te
rn

a
ry



Classification of Proteins – Size

• Most peptides and proteins have 2-2000 amino acids

• Assuming average MW per amino acid of 110 daltons, MW 

range for peptides and proteins in range 220-220,000 

daltons

• Some proteins consist of single polypeptide chain and are 

monomeric

• Others consist of multiple polypeptide chains (sometimes 

identical, sometimes not) and are oligomeric



Terminology



Terminology



Terminology



Terminology



Terminology

protein (generally 300-1000 amino acids)





Functional definition:

Enzymes: Accelerate biochemical reactions

Structural: Form biological structures

Transport: Carry biochemically important substances

Defense: Protect the body from foreign invaders

Structural definition:

Globular: Complex folds, irregularly shaped tertiary structures

Fibrous: Extended, simple folds -- generally structural proteins

Cellular localization definition:

Membrane: In direct physical contact with a membrane; generally water insoluble.

Soluble: Water soluble; can be anywhere in the cell



Protein Domains

• Structural Domain

• Discrete independently folding unit of a protein

• Conserved Domain (sequence-based)

• Protein region with recognizable position-specific pattern of 

sequence conservation

• Sequence-based domains often roughly correspond to 

structural domains

• Domains often have distinct, identifiable functions



Nucleic Acid Structure
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• Primary- sequence of nucleotides

• Secondary- base pairing interactions 

between polymers (DNA) or within a 

single polymer (RNA)

• Tertiary- 3D folding pattern

• Quaternary- interactions of nucleic 

acids with other molecules (DNA, RNA, 

or Protein)



Experimental techniques

Three main research techniques for structural biology. 

According to the statistics of PDB (https://www.rcsb.org/)

https://www.creative-biostructure.com/

https://www.rcsb.org/


X-ray Crystallography

• Requires crystals, which can be hard to make

• Can handle very large proteins and complexes (e.g. ribosome)

• Provides a “flash picture” with little or no data about motions

• Can include packing artifacts from crystallization



Nuclear Magnetic Resonance

• Requires highly concentrated, C13/N15-labeled protein solutions

• Limited to relatively small proteins (<30 kDa)

• Sensitive to molecular motions

• High protein concentrations may induce non-biological binding



Cryo-electron microscopy

• Requires expensive equipment

• Only small amount of sample

• Rapid freezing sample allows sample to maintain a closer-to-

native state

• Useful for biomolecules with high molecular weight



Experimental techniques

Advantages Disadvantages

X-ray 

crystallography

• Well developed

• High resolution

• Broad molecular weight 

range

• Difficult sample prep

• Static crystalline state 

NMR • High resolution

• 3D structure in solution

• Good for dynamic study

• Difficult sample prep

• High sample purity needed 

• Static crystalline state 

captured

Cryo-EM • Simple sample prep

• Structure in native state

• Small sample size needed

• Lower resolution

• Works best for samples with 

high molecular weight

• EM equipment is costly



Structure Prediction Overview

• When no or incomplete structure is available

• Prominent research focus of bioinformatics and 

theoretical chemists

• Drug discovery

• Biotechnology/bioengineering 

• Predicted structures aren’t housed in most 

structural databases

• Structure prediction websites, such as AlphaFold

Protein Structure Database, are housed separately

https://alphafold.ebi.ac.uk/


Structure Prediction Methods

• Comparative Modeling

• Prediction is based on amino acid sequence and 

structures of similar molecules available

• Fold recognition

• Predicts folded structure by aligning a protein of 

unknown structure and a protein of known structure

for low levels of sequence identity (<25%)

• Ab initio

• Predicts the structure of proteins from the sequence 

and using molecular energy calculations 

(Schrodinger equation)



Structure Prediction Example

Casalino et al, Beyond Shielding: The Roles of Glycans in the SARS-CoV-2 Spike 

Protein, PMID:33140034

Impact on COVID-19 research

• Researchers have provided key insights into the 

SARS-CoV-2 proteins through structure prediction

• Identified critical residues

• Contextualized variant perturbations

• Improved understanding of molecular recognition

• Spike fusion glycoprotein example

• Challenging to characterize experimentally

• Modeling + molecular dynamics helped researchers 

understand the roles of glycans on the dynamics of the 

protein



Where do I find structures?

NCBI Structure DatabaseRCSB Protein Data Bank



Protein Data Bank (PDB)

~20 New Structures are deposited daily

Each structure contains:

• 3D atomic coordinates 

• Mandatory Metadata

• Author Information

• Primary citation

• Experimental Data

• Polymer sequence(s)- proteins, 
DNA, RNA

• Small Chemical component 
structures- ligands, inhibitors, etc.



• Updated monthly

• Derived from PDB records

• Additional information added, 
including:

• Explicit chemical graph 
information

• Validation (secondary structure 
elements)

• Includes taxonomy

• Connects 3D to associated 
literature, molecular data, chemical 
data, and other NCBI tools

Structure Database



Search Tips
Entrez is a molecular biology database system that provides access to a 

wealth of NCBI data

• More Entrez Help is available on the NCBI website

Finding structures with Entrez

• Use field limits and Boolean operators

• Put phrases in quotes

“term1”[field1] AND/OR/NOT “term2”[field2] AND/OR/NOT …

https://www.ncbi.nlm.nih.gov/books/NBK3837/


Search Examples

term1[field1] AND/OR/NOT term2[field2] AND/OR/NOT …
Useful Search Fields

Organism

Ex. “Homo sapiens”[orgn]

Experimental Method

Ex. “NMR”[exp]

Chemical Name

“zinc”[chemical name] 

PDB Description

Ex. “Tumor Suppressor 

p53”[title]

[Filter]

Ex. “Complex DNA”[filter]

More Search Field Options

“Homo sapiens”[orgn] AND “X-ray 

diffraction”[exp]

“Homo sapiens”[orgn] AND “X-ray 

diffraction”[exp]AND “zinc”[chemical name]

1TUP

“Homo sapiens”[orgn] AND “X-ray 

diffraction”[exp] AND “zinc”[chemical 

name] AND “Complex DNA”[filter]

https://www.ncbi.nlm.nih.gov/structure/advanced


HEADER    ISOMERASE/DNA                           04-OCT-07   2RGR              

TITLE     TOPOISOMERASE IIA BOUND TO G-SEGMENT DNA                              

COMPND    MOL_ID: 1;                                                            

COMPND   2 MOLECULE: DNA TOPOISOMERASE 2;                                       

COMPND   3 CHAIN: A;                                                            

COMPND   4 FRAGMENT: DNA BINDING AND CLEAVAGE DOMAIN (RESIDUES 419-

COMPND   5 1177);                                                               

COMPND   6 SYNONYM: DNA TOPOISOMERASE II;                                       

COMPND   7 EC: 5.99.1.3;                                                        

COMPND   8 ENGINEERED: YES;                                                     

COMPND   9 MOL_ID: 2;                                                           

COMPND  10 MOLECULE: DNA;                                                       

COMPND  11 CHAIN: C;                                                            

COMPND  12 ENGINEERED: YES;                                                     

COMPND  13 MOL_ID: 3;                                                           

COMPND  14 MOLECULE: DNA;                                                       

COMPND  15 CHAIN: D;                                                            

COMPND  16 ENGINEERED: YES                                                      

SOURCE    MOL_ID: 1;                                                            

SOURCE   2 ORGANISM_SCIENTIFIC: SACCHAROMYCES CEREVISIAE;                       

SOURCE   3 ORGANISM_COMMON: BAKER'S YEAST;                                      

SOURCE   4 ORGANISM_TAXID: 4932;                                                

SOURCE   5 GENE: TOP2, TOR3;                                                    

SOURCE   6 EXPRESSION_SYSTEM: SACCHAROMYCES CEREVISIAE;                         

SOURCE   7 EXPRESSION_SYSTEM_COMMON: BAKER'S YEAST;                             

SOURCE   8 EXPRESSION_SYSTEM_TAXID: 4932;                                       

SOURCE   9 EXPRESSION_SYSTEM_STRAIN: BCY123;                                    

SOURCE  10 EXPRESSION_SYSTEM_VECTOR_TYPE: PLASMID;                              

SOURCE  11 EXPRESSION_SYSTEM_PLASMID: PGAL;                                     

SOURCE  12 MOL_ID: 2;                                                           

SOURCE  13 SYNTHETIC: YES;                                                      

SOURCE  14 MOL_ID: 3;                                                           

SOURCE  15 SYNTHETIC: YES 

REMARK   2                                                                      

REMARK   2 RESOLUTION.    3.00 ANGSTROMS.

REMARK   3                                                                      

REMARK   3 REFINEMENT.                                                          

REMARK   3   PROGRAM     : PHENIX 

…

REMARK 280                                                                      

REMARK 280 CRYSTAL                                                              

REMARK 280 SOLVENT CONTENT, VS   (%): 59.90                                     

REMARK 280 MATTHEWS COEFFICIENT, VM (ANGSTROMS**3/DA): 3.07                     

REMARK 280                                                                      

REMARK 280 CRYSTALLIZATION CONDITIONS: 12-20% PEG 1000, 100-250 MM MGCL2,       

REMARK 280  100 MM SODIUM CACODYLATE, PH 7.0, VAPOR DIFFUSION, HANGING          

REMARK 280  DROP, TEMPERATURE 277K                                              

REMARK 290 

PDB File



ATOM     46  N   THR A 424      17.857  11.128 -95.193  1.00 57.50           N  

ANISOU   46  N   THR A 424     7252   7857   6740    -72    842    107       N  

ATOM     47  CA  THR A 424      16.610  11.906 -95.142  1.00 56.73           C  

ANISOU   47  CA  THR A 424     7153   7780   6623    -85    799    141       C  

ATOM     48  C   THR A 424      15.300  11.135 -94.959  1.00 55.10           C  

ANISOU   48  C   THR A 424     6973   7587   6374   -100    751    126       C  

ATOM     49  O   THR A 424      14.215  11.725 -95.020  1.00 54.92           O  

ANISOU   49  O   THR A 424     6950   7583   6334   -111    717    158       O  

ATOM     50  CB  THR A 424      16.451  12.759 -96.406  1.00 60.37           C  

ANISOU   50  CB  THR A 424     7628   8271   7041    -94    820    182       C  

ATOM     51  OG1 THR A 424      16.550  11.914 -97.557  1.00 63.33           O  

ANISOU   51  OG1 THR A 424     8049   8666   7346   -104    846    163       O  

ATOM     52  CG2 THR A 424      17.523  13.836 -96.462  1.00 61.80           C  

ANISOU   52  CG2 THR A 424     7773   8436   7271    -81    860    209       C 

YX Z

ATOM     46  N   THR A 424      17.857  11.128  -95.193  1.00 57.50

PDB File: Data

Name

Atom

Number

Atom

Name

Residue

Name

Chain ID

Residue

Number

Occupancy

Temperature

Factor

More about PDB Data

https://pdb101.rcsb.org/learn/guide-to-understanding-pdb-data/introduction


Computational Structural Biology

• Structure Prediction- inference of 3D structure from 

sequence data 

• Molecular Docking- predicts the orientation of one molecule 

to another

• Molecular Dynamics Simulations- analyzes physical 

movements of atoms and molecules over time



Computational Structural Biology

• Structure Prediction- inference of 3D structure from sequence data 

• Molecular Docking- predicts the orientation of one molecule to 

another

• Molecular Dynamics Simulations- analyzes physical movements of 

atoms and molecules over time

• Rely on experimental information from public databases

• NCBI Databases and RCSB Protein Data Bank



Ab initio Prediction Comparative Modeling

Applicable to any sequence Applicable to only those sequences with 

recognizable similarity to a template 

structure

Not very accurate (>4Å RMSD) Fairly accurate (<3Å RMSD), similar to

low resolution X-ray structure

Attempted for proteins of <100 residues Not limited by size

Accuracy and applicability are limited by 

our understanding of the protein folding 

problem

Accuracy and applicability are limited by 

the number of known folds

Homology Modeling vs Ab initio Prediction


